Ummmm......

Mechanized warfare in the XXXIV Century

Moderator: go0gleplex

mj12games
Admiral of the Fleet
Admiral of the Fleet
Posts: 3637
Joined: Sun Mar 27, 2005 9:56 pm
Location: Denver, CO
Contact:

Re: Ummmm......

Postby mj12games » Fri May 08, 2009 2:47 pm

jimbeau wrote:probably a stylesheet thing. You probably need an IE only stylesheet?


I confirmed the new stylesheets on Internet Explorer, Firefox, Opera, and Safari...

And the problems being described (links not working, pictures not loading) shouldn't happen because of stylesheets.

I've never had a problem with mj12games.com, but I've noticed that on other sites (Yahoo! for example) the stylesheet doesn't load correctly the first time, but refreshing the page fixes the problem.
Daniel Kast
Majestic Twelve Games
www.mj12games.com

thedugan
Admiral
Admiral
Posts: 1660
Joined: Mon Mar 28, 2005 5:01 am
Location: DFW area - Texas!
Contact:

Re: Ummmm......

Postby thedugan » Fri May 08, 2009 2:57 pm

Yeah, Yahoo has some pages that don't even load right in the versions of IE they use at work.

Gotta agree with Jim, likely a browser problem - downolad and install K-Meleon and Firefox if you can.

Why K-Meleon? It's based on Firefox (technically, the Mozilla code base), but loads faster, is generally lighter memory-wise, and has some tools that work on my computer ("Translate this page from..." and the Favorites plugin) better than Firefox while reading most pages and being faster than Firefox.

Why - Yes, I DO have three browsers on my computer. I had Netscape 3, and a couple of no-names I dont recall, but they were getting too long in the tooth to read most pages....
Becuz I'm da friggin' ART FAIRY - dats why!

Big Bang = Let there be LIGHT!

mj12games
Admiral of the Fleet
Admiral of the Fleet
Posts: 3637
Joined: Sun Mar 27, 2005 9:56 pm
Location: Denver, CO
Contact:

Re: Ummmm......

Postby mj12games » Fri May 08, 2009 2:59 pm

I was right, and I was wrong.

I was right: it was NOT a browser problem.

I was wrong, because I failed to make changes to some coding on the Wardogs pages when I changed the PHP a few weeks back.

Everything's fixed now, thanks to Mike (not Dugan :)).
Daniel Kast
Majestic Twelve Games
www.mj12games.com

thedugan
Admiral
Admiral
Posts: 1660
Joined: Mon Mar 28, 2005 5:01 am
Location: DFW area - Texas!
Contact:

Re: Ummmm......

Postby thedugan » Fri May 08, 2009 3:59 pm

So, we were all half-right...

PHP not rendering the same in different browsers isn't technically a browser problem, it's a standards problem. :ugeek:

Well, it's fixed anyway :D
Becuz I'm da friggin' ART FAIRY - dats why!

Big Bang = Let there be LIGHT!

mj12games
Admiral of the Fleet
Admiral of the Fleet
Posts: 3637
Joined: Sun Mar 27, 2005 9:56 pm
Location: Denver, CO
Contact:

Re: Ummmm......

Postby mj12games » Fri May 08, 2009 4:20 pm

thedugan wrote:PHP not rendering the same in different browsers isn't technically a browser problem, it's a standards problem. :ugeek:


PHP is server-side; it does not interact with the browser at all.

The problem wasn't that the PHP was rendering differently for different browsers, it's that the PHP was providing incorrect HTML, which different browsers have varying tolerances for...
Daniel Kast
Majestic Twelve Games
www.mj12games.com

jimbeau
Vice Admiral
Vice Admiral
Posts: 960
Joined: Sun Mar 27, 2005 9:56 pm

Re: Ummmm......

Postby jimbeau » Fri May 08, 2009 10:17 pm

cricket wrote:
jimbeau wrote:probably a stylesheet thing. You probably need an IE only stylesheet?


I confirmed the new stylesheets on Internet Explorer, Firefox, Opera, and Safari...

And the problems being described (links not working, pictures not loading) shouldn't happen because of stylesheets.

I've never had a problem with mj12games.com, but I've noticed that on other sites (Yahoo! for example) the stylesheet doesn't load correctly the first time, but refreshing the page fixes the problem.


Correct, I saw unformatted links ad assumed it was stylesheets.

Now that we're fixed, the wardogs money should come rolling in!

thedugan
Admiral
Admiral
Posts: 1660
Joined: Mon Mar 28, 2005 5:01 am
Location: DFW area - Texas!
Contact:

Re: Ummmm......

Postby thedugan » Sat May 09, 2009 4:33 am

cricket wrote:
thedugan wrote:PHP not rendering the same in different browsers isn't technically a browser problem, it's a standards problem. :ugeek:


PHP is server-side; it does not interact with the browser at all.

The problem wasn't that the PHP was rendering differently for different browsers, it's that the PHP was providing incorrect HTML, which different browsers have varying tolerances for...


Please select your favorite response.....

My first attempt at a reply wrote:Yes, that was my point....all browsers don't render the pages the same way, given the same source. Hence my assumption it was a browser problem. So, with mis-configured PHP, some browsers would give useable output - others wouldn't. Since it worked (I'm assuming) for you, you assumed it was all good on the PHP side until someone asked about it that had a browser that didn't render it as you intended


My second attempt at a reply wrote: YAAAYYYYY! It works!!! you fixed it!!!!!
Becuz I'm da friggin' ART FAIRY - dats why!

Big Bang = Let there be LIGHT!

koyodude
Midshipman
Midshipman
Posts: 38
Joined: Wed Apr 22, 2009 6:27 pm
Location: Arlington, tx
Contact:

Re: Ummmm......

Postby koyodude » Sat May 09, 2009 5:22 am

hey thanx guys. works like a charm now :D

go0gleplex
Admiral
Admiral
Posts: 1362
Joined: Tue Jul 26, 2005 8:34 pm
Location: Keizer, OR

Re: Ummmm......

Postby go0gleplex » Mon May 11, 2009 11:56 pm

Thanks Dan. (belatedly) :D
"Our past shapes us, our choices define us, our desires propel us, and those we let into our hearts give us the strength to persevere even when our dreams lay shattered behind us." - me


Return to “Wardogs”

Who is online

Users browsing this forum: No registered users and 1 guest